Support Center > Knowledge Base> Article: Final Draft 8 keeps prompting me to activate on Mac OS 10.10 (Yosemite) or 10.9 (Mavericks).

Final Draft 8 keeps prompting me to activate on Mac OS 10.10 (Yosemite) or 10.9 (Mavericks).

Article ID: 39419 Email Print
Question
Final Draft 8 keeps prompting me to activate on Mac OS 10.10 (Yosemite) or 10.9 (Mavericks).

Answer

OS X 10.10 (Yosemite) and 10.9 (Mavericks) will cause Final Draft 8.0.1 to prompt you to activate every time it's opened even though it was successfully activated previously.

To fix this issue, download and install version 8.0.3.1. It will overwrite your existing installation and once it's installed, you should be able to activate and run Final Draft without further problems.

You can download the 8.0.3.1 installer HERE.

If you receive a message that you are out of activations, contact activation support via chat, email, or phone at 818-789-6281.

IMPORTANT: Live technical support (phone, chat, email) for Final Draft 8 will end on December 31, 2017. You will still be able to find information and solutions in this knowledge base, in the online troubleshooter and in the FD8 User Guide.


Related articles...

Article Details
Views: 5788 Created on: Nov 22, 2013
Date Updated: Oct 03, 2017
Tagged: update


Poor Outstanding