Support Center > Knowledge Base> Article: Do I need to have an earlier version of Final Draft on my computer to install the FD10 upgrade?

Do I need to have an earlier version of Final Draft on my computer to install the FD10 upgrade?

Article ID: 1249 Email Print
Question
Do I need to have an earlier version of Final Draft on my computer to install the FD10 upgrade?

Answer

No. Final Draft upgrades are always full installs, which do not need any previous versions on your hard drive.


Related articles...

Article Details
Views: 23566 Created on: Dec 28, 2009
Date Updated: Sep 11, 2016

Poor Outstanding